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With the popularity of the Internet and with
users demanding graphical user interfaces
(GUIs), many IT shops are looking for ways

to Web-enable their existing mainframe applications. This
article will demonstrate how to Web-enable a CICS appli-
cation using the tools available in VisualAge for Java
(VAJ) Enterprise Edition, version 4. It will describe the
steps to create a servlet and Java Server Page (JSP) that
accesses a CICS transaction via the CICS Transaction
Gateway (CTG). Additionally, this article will provide an
overview of how to implement servlets and JSPs in
WebSphere Application Server (WAS) 3.5 for OS/390.

This article will provide you with steps to get started in
developing Java servlet programs to interface with CICS.
It assumes that you have a technical background in CICS,
VTAM and WebSphere under OS/390, and some basic
Java programming ability.

The following software was used as the basis for
this article:

◆ OS/390 V2.10 running CICS Transaction Server (TS)
1.3 and WAS 3.5 for OS/390

◆ Windows NT 4.0 Workstation
◆ CTG 4
◆ VAJ 4 Enterprise Edition

The goal of this example is to Web-enable the sample
FILEA application that is distributed with CICS. I will
demonstrate how to do this using the AMNU transaction
to start the application, and the ABRW transaction to
browse the records in the FILEA VSAM file. The Java
servlet will execute the ABRW transaction and capture all
of the information from the screens until it reaches the end
of the file. It will display all of the captured information
on a single Web page via a JSP.

CICS TRANSACTION GATEWAY (CTG)

The two main interfaces to CICS via the CTG are the
External Call Interface (ECI) and the External Presentation
Interface (EPI). The OS/390 version of the CTG only
supports the ECI. With the ECI, you are using a similar
mechanism as an EXEC CICS LINK; ECI performs a link
to a CICS program using a communications area (com-
marea) for passing data to and receiving data from the
program. The EPI accesses CICS transactions via 3270
screens; it is basically the same as screen scraping. I will
be using the EPI for the example in this article. Since the
CTG for OS/390 only supports the ECI, I will use the
CTG for Windows NT to get the support for EPI.

I installed and configured CTG using the instructions in
the Windows Gateway Administration book. The CICS
client was also installed as part of the CTG. You can
install the Windows version of CTG as an NT service; this
is a good idea if you want to automate the starting of CTG.
APPC and TCP62 are the available communications
protocols for connecting to CICS under OS/390 from the
CTG. I chose TCP62 as the communications protocol to
connect to CICS. A copy of the configuration file for the
CTG (CTG.INI) that I used is included in the file
CLAY0702.ZIP, which is available from the NaSPA
Web site. To access, go to www.naspa.com, click on the
“Technical Support” icon and on “Coding Samples
from Articles.”

VTAM

I configured VTAM under OS/390 to provide connec-
tivity between CICS and CTG. Two VTAM major nodes
were defined: one is a TCP/IP major node, and the other
is a Cross Domain Resource (CDRSC) major node. A
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VTAM mode table entry is also needed for
LU62 support. Figure 1 provides some
examples of each type of node.

CICS

You need to make several changes for
CICS to enable connectivity to the CTG.
The Communicating from CICS on
System/390 manual describes how to do
this. You will need to define connection and
session entries for CICS in CEDA in order to
support LU62 communications with CTG.
Figure 2 shows an example of some connec-
tion and session definitions.

VISUALAGE FOR JAVA
ENTERPRISE EDITION

You must have certain features of VAJ
installed to enable the Enterprise Access
Builder (EAB) tools to generate programs for
accessing CICS. When installing VAJ, you
must include the Transaction Access Builder
and Enterprise Java Beans/Java Server Pages
(EJB/JSP) Development environment. After
you have VAJ installed, you need to add cer-
tain features to the Workbench. You can do
this by performing the following steps:

1. Press F2 for Quick Start.
2. Click on Features>Add Feature>OK.
3. Select the following features:

• Connector CICS
• IBM Common Connector Framework
• IBM Enterprise Access

Builder Library
• IBM Java Record Library
• IBM WebSphere Java Libraries
• IBM WebSphere Test Environment
• Sun Servlet API 2.2

4.Click OK to add the features.

A servlet is a Java program that executes
on a server under a Java Virtual Machine
(JVM). Usually, the JVM is managed by an
application server program, which controls
the environment in which the servlets execute.

The following steps show how to create
the different parts of a Java servlet applica-
tion to access CICS via the CICS EPI
Connector. However, first you need to
create a project and package under VAJ as a
place to keep your Java programs.

To create a new project:

1. Press F2 (for “Quick Start”).
2. Select Basic>Create Project>OK.
3. Give it a descriptive name, and then

click “Finish.”

To create a package within the new project:

1. Right-click on the project that you just
created and select Add>Package.

2. Key in a name for your package. Use
the standard Java naming convention
for packages where the package name
starts with the reverse of a domain name
(i.e., com.chclay.<descriptive name>).

3. Leave all other options at their default
values and click the “Finish” button.

You can use an EAB tool called the 3270
Importer to establish a telnet session with
the CICS region where the FILEA applica-
tion is running. After the connection is
established, you can use this tool to capture
the screen layout for each screen that
becomes part of the interface. The different
fields are selected from each screen and are
given meaningful names. You can use these
layouts to build Java record types and record

classes that will act as interfaces to obtain the
pertinent data from the 3270 screens.

To start the 3270 Importer tool, perform
the following steps:

1. Right click on the package, and select
Tools>Enterprise Access
Builder>Import 3270. The tool will
prompt you for the connection
information for the CICS region.

2. Enter the information and click
“Finish.” An emulator session will
start, along with the 3270 Importer
tool. To use the tool, you should put
the emulator session at the point
where you want to capture screen
information. The first screen you should
capture is a blank CICS screen, since
when you first connect to CICS via
the CTG you will be on a blank screen.

3. Click on the “Parse Screen” button to
capture the fields from the screen into
the tool.

4. Enter the first transaction name on
the 3270 screen (AMNU), and then
press enter.

5. Click on the “Parse Screen” button to
capture the fields from the screen into
the tool.

6. In the “ENTER TRANSACTION”
field type ABRW and press enter.

7. Click on the “Parse Screen” button to
capture the fields from the screen into
the tool.

8. Click on the “Edit” tab to invoke the
editor. From here, you can select
which screen fields you want to be
accessible from your Java programs,
and you can give the fields meaningful
names. Do this for the fields on each
of the three screens. On the blank
screen make the first field accessible
and give it a name. On the AMNU
screen the “ENTER TRANSACTION”
data entry field needs to be accessible
and be given a name. The data output
fields on the ABRW screen need to be
accessible and be given names.

9. Click on the “Generate” tab to set
options for generating a Record Type
and Record for each screen. Make
sure that the project and package
names are correct. It helps to give
them meaningful class names.

10. Select “Custom Records” and leave
“Generate with Notification” turned
off. To generate all of the records, click
on the “Generate all records” button.
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TCP/IP major node:

TCPANYN  VBUILD TYPE=TCP,PORT=397, X
DNSUFX=CHCLAY.COM,                             X     
TCPIPJOB=TCPIPROC                                               

TCPGRP GROUP                                                                
TCPLINE LINE                                                                 
TCPPU  PU    NETID=NETAPRD                                                   

CDRSC major node:

TCPCDRSC VBUILD TYPE=CDRSC                                                     
TCPCDRSG GROUP                                                                
CTG4CLNT CDRSC  ALSLIST=TCPPU,MODETAB=MODTAB1,DLOGMOD=SNALU62                  

Mode table entry:

SNALU62  MODEENT LOGMODE=SNALU62,TYPE=X’00’

FIGURE 1: TWO VTAM MAJOR NODES
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11. Close the EAB tool. In your workbench,
under the package, you should see sev-
eral Java classes that were generated.

You will be using a Java Server Page
(JSP) to display your results. A JSP is an
HTML file with imbedded JSP directives
and Java code. You will need a servlet data
class to hold your data for sending and
receiving data to or from a JSP. This data
class will be passed to the JSP via the
callPage method of the PageListServlet class.

You can create the servlet by performing
the following steps:

1. Right-click on the package name,
select Add>Class.

2. Enter a descriptive class name and
click on the “Browse the class when
finished” option, and “Finish.” You
should see a window that allows you
to edit the class you have created.

3. Click on the “BeanInfo” tab so that you
can add properties (better known as
variables) to the servlet data class. The
properties are values that you will be
sending to your Web page. They usually
contain variables from your CICS maps,
as well as other variable information
that you want to either display to or
receive from your Web pages.

4. To add properties, click on the
button in the toolbar that looks like
a gray circle with a “P” in the
middle (or select Features>New
Property Feature).

5. Enter a property name using the
Java standard for property names:
The first letter should be lowercase
and every subsequent first letter
in a word should be uppercase;
for example: “thisVariableName”.
The property type should correspond
to the type of ivariable this will be;
like an integer, string, BigDecimal
(for decimal numbers) or a property
can be an indexed array of the
various types.

6. Set the property to Readable
and Writable.

7. Turn on the Indexed option if the
property is an array. In the example,
you created three properties that are
arrays; one for each of the columns on
the ABRW screen.

8. Turn off the bound option, and leave
off the constrained option, as these
options are not needed.

TECHNICAL SUPPORT • JULY 2002

Connection:

Connection    : CL02
Group        : APPCLNT2
DEscription ==>

CONNECTION IDENTIFIERS
Netname    ==> CTG4CLNT
INDsys    ==>

REMOTE ATTRIBUTES
REMOTESYSTem ==>
REMOTEName ==>
REMOTESYSNet ==>

CONNECTION PROPERTIES
ACcessmethod ==> Vtam      
PRotocol   ==> Appc               
Conntype    ==>                    
SInglesess  ==> No                 
DAtastream  ==> User               
RECordformat ==> U
Queuelimit  ==> No                    
Maxqtime    ==> No                 

OPERATIONAL PROPERTIES
AUtoconnect ==> Yes                
INService   ==> Yes                

SECURITY
SEcurityname ==>
ATtachsec   ==> Local              
BINDPassword  :                    
BINDSecurity ==> No                 
Usedfltuser ==> No                 

RECOVERY
PSrecovery  ==> Sysdefault      
Xlnaction   ==> Keep               

Sessions:

Sessions     : CL02LU62
Group       : APPCLNT2
DEscription ==>

SESSION IDENTIFIERS
Connection ==> CL02
SESSName    ==>
NETnameq    ==>
MOdename    ==> SNALU62

SESSION PROPERTIES
Protocol    ==> Appc               
MAximum     ==> 004 , 001          
RECEIVEPfx  ==>
RECEIVECount ==>                    
SENDPfx     ==>
SENDCount   ==>                    
SENDSize    ==> 04096              
RECEIVESize ==> 04096
SESSPriority ==> 000         
Transaction :

OPERATOR DEFAULTS
OPERId      : AS4
OPERPriority : 000         
OPERRsl    : 0           
OPERSecurity : 1           

PRESET SECURITY
USERId     ==>

OPERATIONAL PROPERTIES
Autoconnect ==> Yes         
INservice      :             
Buildchain  ==> Yes         
USERArealen ==> 000         
IOarealen   ==> 00000 , 00000
RELreq     ==> Yes          
DIscreq     ==> Yes          
NEPclass   ==> 000         

RECOVERY
RECOVOption ==> Sysdefault       
RECOVNotify  : None

FIGURE 2: CONNECTION AND SESSION DEFINITIONS 



9. Next, click on “Finish” to complete
the property. Repeat the previous steps
for every property that you plan to use
for input and/or output to the user.

10. Close the window when you are
finished with all of the properties.

To perform the interaction with CICS, you
need to generate Command classes. These
classes will interface with CICS via the EPI
connector. Using the previous example, you
need to build three command classes.

To build the command class, perform the
following steps:

1. For each Command class select
Workspace>Tools>Enterprise
Access Builder.

2. Select “Create Command.”
3. Specify your project and package

names that are being used for this
example. Give each Command class a
descriptive name. Each Command
class needs a connection specification
to define how to communicate to the
CTG and CICS. I will demonstrate
how to build a connection specification
in your servlet (described later), so it
is not necessary to select a connection
specification for the Command class.

Each Command class needs an interaction
specification that describes how the class will
interact with CICS. To select an interaction
specification perform the following steps:

1. Click “Browse” for “InteractionSpec.”
2. Select “EPIInteractionSpec” since

you will be using EPI as your
CICS connector.

3. Click on “OK” to close the window.
4. Click “Next” to continue to select the

input and output record beans.
5. Turn on the “Implements IbyteBuffer”

option unless it is already activated.
6. Click on the Browse button and select

the class name of one of the records
that was created earlier. For the first
Command class use the record created
for the blank screen. For the second
Command class use the record created
for the first screen of the AMNU
transaction. For the third Command
class use the record created for the
ABRW transaction.

7. If the same record is being used for
both input and output, turn on the
“Use input bean type as output bean

type” option. This is done for the third
Command class. If you are not using
the same record for both input and
output you can add the record that you
created for output under “Output
record beans.” For the first Command
class use the record created for
the first screen of the AMNU
transaction. For the second Command
class use the record created for the
ABRW transaction.

8. Click “Finish” to create the command.

The Command Editor is started, which
lets you verify and change your Command.
To do this:

1. Click on the folder named “Input.”
2. Click on the record entry in the

right-hand column.
3. At the bottom of the screen you

should see a table of properties
and values. Right-click on each
property that will be part of your
input page (or a value that you
need to set in your command class
before execution).

4. Select “Promote Property.” Promoting
the property will allow you to set and
retrieve property values. A green circle

should appear to the left of each
promoted property.

5. For the first Command class select the
blank input screen field that you created
earlier and promote it.

6. For the second Command class select
the transaction name field that you
created earlier and promote it.

7. For the third Command class select
the output fields from the ABRW
screen record and promote them.

8. Click on the folder named “Output”
and then click on the record entry in
the right-hand column. You should see
a table of properties and values at the
bottom of the screen.

9. Right-click on each property that will
be part of your output page (or a value
you need to get from the command
class after execution), and select
“Promote Property.” A green circle
should appear to the left of each
promoted property.

10. For the first Command class select the
transaction name field that you created
earlier and promote it.

11. For the second and third Command
classes select the output fields from
the ABRW screen record and
promote them.
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//  Set up connection to CICS via the CTG
com.ibm.connector.cics.CICSConnectionSpec connSpec = new

com.ibm.connector.cics.CICSConnectionSpec();
connSpec.setURL(“tcp://192.168.0.4:2006”);  // the url of the CICS

Transaction Gateway
connSpec.setCICSServer(“CICSTT00”);        // the server name defined in

the CTG
com.ibm.connector.Communication comm = connSpec.createCommunication();

comm.connect();

// Create Commands 
cmd1 Com1 = new cmd1();

// Start AMNU transaction
Com1.setCommunication(comm);
Com1.setBlank(“AMNU”);
Com1.execute();

FIGURE 3: SETTING THE CICS COMMUNICATIONS AND
EXECUTING A COMMAND CLASS IN A SERVLET 

<?xml  version=”1.0”?>
<servlet>

<page-list>
<default-page>

<uri>/TestServletResults.jsp</uri>
</default-page>

</page-list>
<code>com.chclay.test.TESTServlet</code>

</servlet>

This file is created and placed in the servlet path directory specified above.

FIGURE 4: A SAMPLE .SERVLET FILE 
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12. Save the Command and close the
window to complete the Command.

SERVLET AND JSP

You can perform the following steps to
create a servlet:

1. Right-click on the package that you
are working with and select “Add”
and then “Servlet.”

2. Enter a descriptive class name.
3. Under “Advanced Options,” select

Inherit from PageListServlet>Import
Java bean. For our example, you need
to add the following import statements
(using the “add packages” button):

• com.ibm.servlet.*
• com.ibm.webtools.runtime.*
• java.io.*
• javax.servlet.*
• javax.servlet.http.*
• java.util.*

4. Click “Next” and then click the
“Browse” button to find the Java bean
that is the Servlet Data class that was
created earlier. For testing under the
WebSphere Test Environment, enter
an Alternate Web resources path that
is the default WebSphere Test
Environment path.

For the document path, browse to or enter
the following path:

C:\Program Files\IBM\VisualAge for
J a v a \ i d e \ p r o j e c t _ r e s o u r c e s \ I B M
WebSphere Test Environment\hosts\
default_host\default_app\web\

For the servlet path, browse to or enter
the following path:

C:\Program Files\IBM\VisualAge for
J a v a \ i d e \ p r o j e c t _ r e s o u r c e s \ I B M
WebSphere Test Environment\hosts\
default_host\default_app\servlets\

You should set the “Scope” to “request”
to allow the servlet to pass the servlet data
to the JSP.

5. Click “Next” to continue to enter the
fields that you need on the input and
results pages. In our example, the
input page will contain no input fields.
It will contain only a submit button.
The output page will contain the output
fields from the Servlet Data class.

6. Click the “Add” button for the fields
displayed on the results page.

7. Choose the methods (i.e., properties or
variables) that you want to be on the
results page. You can use the Up and
Down buttons to change the position
of the fields on the page. You can
edit the attributes of each field by
highlighting the field and clicking on
the Properties button.

8. Click “Next” to continue.
9. On the “Attributes” page select the

public modifier for the new class
(should be set on as default).

10. Select the “Methods which must
be implemented” option and
click “Finish.”

You should now have a basic servlet created
in your package. However, you must make
changes to support the calling of the CICS
program, moving values from the record
object to the servlet data object, etc. Creating
this servlet also generated an input HTML
and output JSP that are located in the docu-
ment path directory specified when creating
the servlet. A copy of the example files,
including the modified servlet, HTML and
JSP are available in the file CLAY0702.ZIP,
which you can download from the NaSPA
Web site. To access, go to www.naspa.com,
click on the “Technical Support” icon and
on “Coding Samples from Articles.”

The servlet class contains several meth-
ods. The “performTask” method needs to be
modified in order to add the necessary Java
code to set the communications and interac-
tion parameters for the Command classes,
execute the Command classes and to build
the data to be passed to the JSP. Figure 3

shows an example of setting the CICS com-
munications and executing a Command
class in a servlet.

Another file created by VisualAge for Java
is an XML file called <servlet-class-
name>.servlet. The servlet uses this file to
obtain certain information, such as parameters
(with values), what JSP to use as a default, etc.
You will need to place a “servlet” file in the
CLASSPATH of the corresponding servlet. A
sample “servlet” file is shown in Figure 4.

You can use the VAJ WebSphere Test
Environment (WTE) to test servlets before
they are placed on a Web server. To start the
WTE, set the proper classpath information,
and to begin testing a servlet select
Workspace>Tools>WebSphere Test
Environment. The “WebSphere Test
Environment Control Center” will appear. To
edit the classpath, select “Servlet Engine” and
click “Edit Class Path.” Click the “Select All”
button to add all projects to your classpath.
Click the “Start Servlet Engine” button to
start the WTE. This will take a few moments.
You can test the servlet once the Servlet
Engine is started (a console window will
appear and tell you that it has been started).

To test your servlet, bring up your
browser and enter the following URL:

http://localhost:8080/<your-input-
page>.html

(for example: http://localhost:8080/TestInput.html
)

WEBSPHERE APPLICATION
SERVER 3.5 FOR OS/390

This article assumes that you have
already installed and configured WAS, as
well as the HTTP server.
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deployedwebapp.test.host=default_host
deployedwebapp.test.rooturi=/test
deployedwebapp.test.classpath=/local/was/test/servlet:/local/was/test/servlet/test.jar
deployedwebapp.test.documentroot=/local/was/test/web
deployedwebapp.test.autoreloadinterval=60000
webapp.test.jspmapping=*.jsp
webapp.test.jsplevel=1.0
webapp.test.filemapping=/
webapp.test.servletmapping=/servlet

FIGURE 5: ADDITIONS TO WAS.CONF

Service /*.jsp  /usr/lpp/WebSphere35/AppServer/bin/was350plugin.so:service_exit
Service /test/servlet/*
/usr/lpp/WebSphere35/AppServer/bin/was350plugin.so:service_exit
Service /test/*.jsp
/usr/lpp/WebSphere35/AppServer/bin/was350plugin.so:service_exit

Pass /test/*  /local/was/test/web/*

FIGURE 6: HTTPD.CONF 
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The code in Figure 5 was added to was.conf for the test application.
Additions were also made to the HTTP server configuration file to
support the test application. The file, which is shown in Figure 6, is
called httpd.conf and is located in the /etc directory.

Once you have completed your testing in the WTE under VAJ,
you will want to copy the servlets and JSP and HTML files to
make them available for WAS under OS/390. Based on the con-
figuration in Figure 5, the “.servlet” and “.class” files are to be
located in subdirectories at: /local/was/test/servlet, and the JSP,
HTML and any image files are to be located in subdirectories at
/local/was/test/web.

To get the compiled class files from VAJ you can follow
these steps:

1. Right-click on the package/class that you want to export.
2. Select “Export.”
3. The export destination should be set to “Jar file” or

“Directory.”
4. Click “Next.”
5. Select “Browse” to select a directory on your hard drive or to

enter a jar file name. Remember where you selected to place
the files.

6. Under “What do you want to export?” the “class” button
should be selected; “java” and “resources” should be
un-selected (unless you want a copy of the source published
as well).

7. Click on the “Details” button to see exactly which class files
will be published; you can also select and de-select files as
necessary from the Details window. Close the window when
finished by clicking “OK”.

8. Click “Finish” to export the files.

You can use a FTP client to log on to OS/390 and transfer the
files from your workstation. The following describes from our
example configuration where to put the different file types on
the host:

◆ FTP the “jar” or “class” files to the /local/was/test/servlet
directory in binary mode.

◆ FTP the “.servlet” files to the /local/was/test/servlet directory
in ASCII mode.

◆ FTP the “.html” and “.jsp” files to the /local/was/test/web
directory in ASCII mode.

SUMMARY

Using the examples provided here, you should be able to easily
create your own Java servlets to access CICS. Not only will you
gain experience with Java, but you can also make your existing
CICS applications easier to use and more productive.
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