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Many applications maintain their own logs to report the
success and failure of certain processes. However, there
is overhead associated with using

an application log file. For example, you
must manage the log file and occasionally
prune old records. Additionally, computer
operators must know where the log file is
located and how to access the information
in the application’s log file.

The Windows Event Log is a much sim-
pler application reporting method.
Computer operators already know how to
access the Event Log records, and most
shops have processes in place to manage
the logs. This makes life easier for the
computer operator by using a standard
method for application event reporting.
Using the Windows Event Log also
relieves the developer from having to
maintain a separate application log file.

Many network-monitoring packages have
the ability to monitor the Windows Event
Log. You can direct these monitoring tools
to perform such functions as paging the
on-call support personnel when a tragic
event occurs. You can control which
records are written to the Windows Event
Log and configure your network-monitor-
ing package to page out on critical errors, or to email the end user
upon the success of your application. This allows you to utilize

standard processes already in place in your organization to support
your application.

This article will show you how to write
records to the Windows Event Log from a
Win32 Console application. The program
illustrated in this article was developed on a
Windows 2000 Professional machine using
Microsoft Visual C++ version 6.0.

STARTING THE PROJECT

First, you will need to start a new project
in Visual C++. Start Visual C++ and perform
the following steps:

1. Click on File > New.
2. Click on Projects Tab > Select Win32

Console Application.
3. Enter a Project Name (in this example

I chose EvtTst).
4. Select “An Application that supports

MFC” as shown in Figure 1.

CREATING A MESSAGE FILE

Next, create a message file. The mes-
sage file contains two sections. The category
section describes the different categories

of messages that the application will use. The messages section
describes the actual messages that will be written to the event
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log. The following sections will show you how to create a
message file.

Setting up the Message Compiler
First, you need to create a message file to set up the message com-

piler function. The message compiler is used to compile your message
file. Perform the following steps to set up the message compiler:

1. Click on Tools > Customize.
2. Click on the Tools Tab.
3. Click on the “New” icon.
4. In the “Menu Contents” Area, enter “Message Compiler.”
5. In the command area, enter “C:\Program Files\Microsoft

Visual Studio\VC98\Bin\mc.exe.” The location of mc.exe
may be different on your system. You can use the Browse
button to search for mc.exe.

6. Click on the arrow in the Arguments line, and then click on
“File Name.”

7. Click on the arrow in the Initial Directory line, and then click
on “File Directory.”

8. Click on the “Use Output Window” button. The completed
dialog box is shown in Figure 2.

9. After clicking on close, the Message Compiler tool will be
added to your Tools drop-down menu, as shown in Figure 3.

Creating the Message File
Now it is time to create the message file. With your Workspace

open, click on File > New > Text File. Name the file something
meaningful. In this example, I named the file EvtTstMsg.mc.
(Note: The extension of the file name must be “.mc”.)

Enter your message file using the text shown in Figure 4 as a
template. I had a difficult time finding information on the Message
File syntax and parameters. With a bit of trial and error and the help
of some sketchy information I found on the Web, I pieced together
the message file shown in Figure 4. In this section, I will attempt to
convey what I have learned about message files.

The message file contains two distinct sections: the category section
and the message section. The category section (the first seven lines
shown in Figure 4) defines the category of the message. This category
name (“Test Category” in this example) will be shown in the Event
Viewer window when your message is viewed. The message section
contains information about each message that your application will
write to the Event Log. In this example, you have one category and
one message. Each set of definitions must be followed by a period (.).
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FIGURE 1: CREATING A NEW PROJECT THAT SUPPORTS MFC FIGURE 2: SETTING UP THE MESSAGE COMPILER

FIGURE 3: THE MESSAGE COMPILER ON YOUR TOOLS MENU

FIGURE 4: A SAMPLE MESSAGE FILE

©2001 Technical Enterprises, Inc. Reproduction of this document without permission is prohibited.



Let us examine the individual statements
in the message file:

◆ MessageID — Each message must
have a unique ID associated with it. In
your program, you will pass a message
ID number that will be used by the
Event Log to determine which message
should be written to it.

◆ Facility — I assume this parameter
tells the Event Log function to write
your message in the “Application”
section of the event log, as opposed to
the System or Security sections.

◆ Severity — I am not sure exactly what
this parameter does. If I entered anything
but “Success” my program would fail.

◆ SymbolicName — When the message
file is compiled, a header file is produced.
This header file can be included in your
program, and the SymbolicName can
be used to reference your messages.

◆ Language — Specifies the language
you are using.

◆ Free Text — Notice the free text at the
end of each section. The category section
contains the words “Test Category”
while the message section contains the
words “This message came from the
Message File.” The message section
also contains “%1” and “%2”. These
are placeholders for strings that you
will pass to the Event Log from your
program. You will see how these free
text areas are used a bit later.

Once you have created your message file,
click on Tools > Message Compiler.

Note: You must make sure that your message
file is in focus before starting the Message
Compiler. This compile process will create a
file named (in this example) EvtTstMsg.rc.
This file will be used in the following section.

Including the Message File with the
Project

Now that you have created a message file,
you must include the “rc” file with your
project. You can accomplish this by per-
forming the following steps:

1. With your Workspace open, click on
the Resource tab. Right click on the
resources entry, and then click on
“Resource Includes.” Enter the
following in the “Read-only symbol
directives” box, as shown in Figure 5:

#include “filename.rc”

2. Click on OK, and you will receive the
warning shown in Figure 6. Click OK
on this warning screen.

3. Modify the Registry to tell Windows
about your message system.

4. Before you can begin writing records
to the Event Log, you must tell
Windows your intentions and where to

find the message file. In this example,
I used regedt32.exe to manually modify
the Registry. In a real-world situation,
your set up program would perform the
Registry modifications for the end user.

The keys shown in Figure 7 were added in
the HKEY_LOCAL_MACHINE > SYSTEM
> Services > Eventlog > Application area. Let
us examine the keys that were entered:
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FIGURE 5: YOU MUST INCLUDE THE MESSAGE FILE IN YOUR PROJECT

FIGURE 6: CLICK OK ON THIS WARNING SCREEN

FIGURE 7: ADDING KEYS TO THE REGISTRY TO DEFINE THE EVENT LOG
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◆ CategoryCount — This DWORD
specified how many category entries
are contained in your message file.
In this example, you have one
category entry.

◆ CategoryMessageFile — This string
specifies where your category file is
located. You can split your message file
into two separate files — a category file
and a message file. In this example,
both category entries and message
entries were entered into a single file.
This file is included in your executable
program so you enter the path and
name of your executable.

◆ EventMessageFile — This string
specifies where your message file is
located. Again, the category and
message file are one in the same
and are included in your
executable program.

◆ TypesSupported — From what I have
learned, this DWORD must always
contain a 0x7.

CODING TIME

You are finally ready to write some code.
Edit your .cpp file (EvtTst.cpp in this
example) and add the code shown in Figure
8. The code should be placed right after the
“// TODO: code your application’s behavior
here.” line.

First, define a string containing the name
of your event log (EvtTst in this example).
This is the name of the key that you added
to the Registry previously. Next, define a
HANDLE named hEvent. Pass the string to
the RegisterEventSource routine. If this
routine is successful, a handle to your
event log will be returned in hEvent.
Notice that you also pass a NULL as the
first parameter. You can enter the UNC of
another server in this parameter, or if you
pass a NULL, the operation is performed
on the local machine.

The next few lines define the parameters
that you will be passing to the
ReportEvent routine. ReportEvent is used

to perform the actual writes to the Event
Log. Take a look at each of the parameters
passed:

◆ wType — This WORD specifies the
type of event to be logged. The possible
values are:

EVENTLOG_ERROR_TYPE
EVENTLOG_WARNING_TYPE
EVENTLOG_INFORMATION_TYPE
EVENTLOG_AUDIT_SUCCESS
EVENTLOG_AUTIT_FAILURE

◆ wCategory — This WORD picks out
the message category from our message
file. In this example, I specified the
number 1 for this parameter. This “1”
relates to the MessageID=1 statement
in your message file.

◆ dwEventID — This DWORD picks out
the message from your message file. In
this example, I specified the number
100 for this parameter. This “100”
relates to the MessageID=100 statement
in your message file.

◆ lpUserSID — This PSID can be used
to include the user’s SID in the event
log message. In this example, you do
not care about this information, so you
can define it as a NULL.

◆ wNumStrings — You can pass strings
from your program that will be added
to your event log messages. In this
example, you will be passing two strings
to be included. When records are written
to the event log, the text contained in
the message file is written first, and
then the passed strings are written.

Note: In order to have your strings written
to the Event Log, you must define place-
holders for the string(s) in the message file.
This was done using the “%1” and “%2”
statements in the message file. See Figure 4.

◆ dwDataSize — This DWORD specifies
the length of the raw data. Since you are
not displaying any raw data in this
example, you can assign this variable to 0.

◆ lpStrings — This parameter contains a
pointer to a buffer containing an array
of strings. These strings will be
displayed in your Event Log message.

◆ lpRawData — This is a pointer to the
raw data to be displayed. Since you are
not displaying any raw data in this
example, you can assign this variable
to NULL.
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FIGURE 8: THE MAIN CODE

FIGURE 9: THE SOURCE, CATEGORY AND EVENT PARAMETERS

©2001 Technical Enterprises, Inc. Reproduction of this document without permission is prohibited.



Next, simply call ReportEvent, passing the parameters established
above. Then, call DeregisterEventSource to clean up.

TESTING THE APPLICATION

Once you get a clean compile, you are ready to test your application.
However, before you begin testing, you must move your executable

to the location you specified in the Registry for the
EventMessageFile. See Figure 7. If you skip this step, Windows
will not be able to locate your message file.

Note: If you have the Event Viewer application open when copying
your executable to the final destination, you must close and reopen
the Event Viewer after the copy operation.

If all goes well, using the Event Viewer, you should see your
message after executing the application, as shown in Figure 9.
Notice how the Source, Category and Event parameters are displayed
in Figure 9.

If you open the record, you should see the screen shown in Figure
10. Notice the strings included in the message. The message
defined in the message file is printed along with the two strings you
passed to the ReportEvent function.

CONCLUSION

To make this program more versatile, you could modify it to
accept command line parameters. These parameters could include
the text strings to be printed in the Event Log and/or the Message
ID. This type of a modification would allow you to include this
application in BAT files or scripts to report the success or failure of
a given process.

NaSPA member John E. Johnston is the
owner of a Web development company that
specializes in e-commerce. John also per-
forms contract work on Novell, NT and Unix
networks. He can be contacted via email at
johnj@fast.net.

WWW.NASPA.COMTECHNICAL SUPPORT • DECEMBER 2001

FIGURE 10: THE THREE STRINGS CONTAINED
IN THE FINAL MESSAGE (ONE FROM THE MESSAGE
FILE AND TWO FROM THE CODE)


